
The PPP/SLIP Connect Application

The PPP/SLIP Connect application enables you to establish connections to remote 
networks using PPP (Point-to-Point Protocol) or SLIP (Serial Line Internet Protocol) 
through your PCs COM port and a modem. When you dial in to a remote network, 
your PC becomes a node on that network with the same networking features 
available to your PC as if it was directly connected to the network.

The PPP/SLIP Connect application contains many features necessary for you or a 
network administrator to take full advantage of the services offered by a PPP or SLIP 
connection. Once you, or your administrator, have predefined the required 
connection settings, you will normally only use a few of the capabilities of PPP/SLIP 
Connect.

The following Help topics are available:

Getting Started with PPP/SLIP Connect 

The PPP\SLIP Connect Reference 

Administrative Mode 

Index 
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Getting Started with PPP/SLIP Connect

The PPP/SLIP Connect application contains a wide range of features that help you 
communicate with a remote network via a modem. The information provided in this 
section demonstrates the basic features so that you can start using the PPP/SLIP 
Connect application with the default settings. Once you are familiar with the basic 
features, you can continue to explore other features with the help of the PPP\SLIP 
Connect Reference.

This section discusses the following topics:
Starting the PPP/SLIP Connect Application 
Configuring Modem Information 
Sites and Sessions 
Connecting to a Remote Site
Disconnecting from a Remote Site
Other PPP/SLIP Connect Features 



Starting the PPP/SLIP Connect Application

To start the PPP/SLIP Connect application, double-click on the PPP/SLIP Connect icon 
in the TCP Pro program group.



Configuring Modem Information

Before you can use the PPP/SLIP Connect application to connect to a remote site, you 
need to provide the following information about your modem.

- The modem type (for example, US Robotics WorldPort 14400)
- The COM port to which your modem is connected

To configure your modem for use with the PPP/SLIP Connect application:
1. Select Modem Port Setup from the Options menu to open the Modem Port Setup 

dialog box.
2. Provide the information listed above in the appropriate fields.

Note: If you do not know your modem type, select Default Modem Settings from 
the drop-down list of the Modem field.

3. Click on the OK button.

All the fields and buttons in the Modem Port Setup dialog box are described in the 
Modem Port Setup dialog box.



Sites and Sessions

Sites and sessions are used by the Connect application to establish connections to 
remote networks. Sites describe static information about the network(s) you intend to
access, for example, the telephone numbers and protocol to be used. Sessions 
contain information about a connection that usually changes, for example, your user 
name and password and the local area code from where you are calling.

Before you can connect to a remote network, you must:
1. Define a Site 
2. Define a Session 



Defining a Site

You must provide certain information about the remote sites to which you want to 
connect before you can establish a connection. Remote site information is created 
and maintained by the PPP/SLIP Connect application in a file called SITE.INI. Your 
network administrator may have already provided this information. If a SITE.INI is 
not provided to you, you must define site information by providing the following 
information about each remote site to which you want to connect: 

- The telephone number 
- The protocol being used (PPP or SLIP)
- The handshaking script (if necessary)
- The IP addresses that are assigned to you by the remote site (if they are not 

included in the handshaking script)

To define a remote site:
1. Select Preferences from the Options menu, check the Administrative mode 

box, and then click on OK to enable Administrative mode.
2. Select Site Setup from the Options menu to open the Site Setup dialog box.
3. Enter the information listed above in the appropriate fields and click on the OK

button.

All the fields in the Site Setup dialog box are described in the Site Setup dialog box.



Defining a Session

To be able to connect to a remote site, you have to associate the remote site with a 
session. A session consists of the following information:

- Your user name and password for the remote site (by default, a session is 
configured so that you are prompted for your user name and password at 
connection time).

- Dialing information specific to your location (your local area code) and any 
special dialing information needed (the prefix 9 to dial out of a private 
exchange or additional numbers for a calling card).

To define a session, follow the steps below:
1. Select Session Setup from the Options menu to open the Session Setup dialog 

box.
2. Enter a descriptive name for the session you want to define in the Session 

field.
3. Select the site you want to reference from the drop-down list in the Site field.
4. Enter the information listed above in the appropriate fields of the Session Setup

dialog box.
All the fields and buttons in the Session Setup dialog box are described under 
the Session Setup dialog box.

5. Click on the OK button to save the information and exit the Session Setup 
dialog box.
The session name you defined appears in the Connect pulldown menu.



Connecting to a Remote Site

Once you have provided all the necessary information to configure the PPP/SLIP 
Connect application for use, you can establish a connection to a remote site by 
selecting the session name from the list of defined sessions in the Connect pulldown 
menu.

The PPP/SLIP Connect application attempts to establish a connection to the remote 
site. Once a connection is established, the status area of the status bar indicates On 
line.

Note: If you provided multiple telephone numbers for the remote site to which you 
are connecting and the first number you provided is busy, the alternate numbers will 
be attempted in sequence.



Disconnecting from a Remote Site

To disconnect from the remote site to which you are currently connected, select 
Disconnect from the Connect menu.

Note: When you exit the PPP/SLIP Connect application, your connection to a remote 
site is not automatically terminated. However, you can configure PPP/SLIP Connect to 
automatically terminate the connection to a remote site upon exit by selecting 
Disconnect on PPP/SLIP Connect Exit in the Preferences dialog box. (The Preferences 
dialog box opens when you select Preferences from the Options menu.)



Other PPP/SLIP Connect Features

Now that you are familiar with the basic features, you can continue to explore the 
many features that the PPP/SLIP Connect application has to offer. With PPP/SLIP 
Connect, you can:

- Configure your system to beep when connecting to and/or disconnecting from 
a remote system by selecting Preferences from the Options menu.

- Disconnect from a remote site automatically when you exit the PPP/SLIP 
Connect application, or when you exit Windows, by selecting Preferences from 
the Options menu.

- Display all handshake messages and IP addresses during the handshaking 
process by selecting Preferences from the Options menu.

- Configure the application to connect to a remote site automatically when the 
first Windows Sockets related network request is made by selecting Auto 
Connect Setup from the Options menu.

The PPP/SLIP Connect application lets you perform the following tasks only if you are 
in Administrative mode, which is accessed by selecting Preferences from the Options 
menu.

- Save to a file or print any data displayed in the PPP/SLIP Connect window by 
selecting the appropriate menu item from the    File menu.

- Copy and paste data between the Windows clipboard and the PPP/SLIP Connect
window by selecting the appropriate menu item from the Edit menu.

- Experiment with a modem or a remote site by typing characters manually in 
the PPP/SLIP Connect window by selecting Interactive from the Connect menu.

- Display information about the PPP/SLIP driver or information about the 
connection that is currently established by selecting the appropriate menu 
item from the    Status menu.

- Customize the colors and fonts used in the PPP/SLIP Connect window by 
selecting the appropriate menu item from the Options menu.

- Record all interactions with the modem and the remote site as well as any error
messages that may occur while the PPP/SLIP Connect application is running. 
You can save the information to a file by selecting Log to File from the Options 
menu or display the information in the TCP Pro Console by selecting Log to 
Console from the Options menu.



The PPP\SLIP Connect Reference

This section introduces you to the main window of the PPP/SLIP Connect application 
and describes each pulldown menu, menu item, and dialog box in detail.

When you start the PPP/SLIP Connect application, the PPP/SLIP Connect window 
appears on your screen. The PPP/SLIP Connect window is the main window of the 
PPP/SLIP Connect application. It contains the following:

The Display area 
The Status bar 
The   File   menu  
The Connect menu

The Stop! Menu 

The Options menu



The Display Area

The display area shows any interactions with the modem and the remote site to 
which you are connecting, and any error messages that may occur while the PPP/SLIP
Connect application is running.

Note: The display area only displays the information listed above if you select Log to 
Screen from the Options menu. Log to Screen is only available in the Options menu if you
are in Administrative mode. 

The display area is also used to type commands to a modem or a remote site (this is 
called Interactive mode). To select Interactive mode, select Interactive from the Connect
menu. The Interactive menu item is only available when you are in Administrative 
mode.



The Status Bar

The status bar is located at the bottom of the PPP/SLIP Connect window. It contains 
five areas, described from left to right:

An information area, which displays error messages and information that helps
to explain the task you are performing. This area also displays the changing 
status of the handshaking and negotiation with a remote site.
An area which displays the remote access mode (PPP or SLIP) when you are 
online. If you are in Interactive mode, this area indicates whether the 
keyboard is in insert mode (Ins) or overstrike mode (Ovr).
An area which displays the baud rate of your modem if it can be determined at
modem connect time. If a direct connection is being used, this area remains 
empty.
An area which displays the time in hours, minutes, and seconds since the 
modem connected. If a direct connection is being used, this area remains 
empty. 
A status area, which indicates the following:

Off Line when you are not connected with a remote site. 
On line, when you are online in PPP or SLIP mode with the remote site and 
applications can communicate over the connection.
Interactive, when the screen is available for typing commands to and 
displaying responses from the modem or remote site.



The File Menu

The File pulldown menu contains the Exit menu item, which exits the PPP/SLIP 
Connect application.

IMPORTANT: Selecting Exit does not disconnect the current remote connection upon 
exiting the application. However, you can configure the PPP/SLIP Connect application 
to disconnect automatically upon exit by selecting Disconnect on PPP/SLIP Connect Exit 
in the Preferences dialog box (for more information, refer to Preferences).



The Connect Menu

The Connect pulldown menu contains the menu items listed below as well as a list of 
session names that have been defined. A session is a collection of information that 
describes the way you access a particular remote site. Selecting a session name from
the list lets you connect to a remote site.

Connect
Disconnect



Connect

The Connect menu item lets you select a session and establish a connection to a 
remote site using the site information defined for the session. 

When you select Connect, the Connect dialog box opens.

IMPORTANT: To be able to connect to a remote site, you must first define a session 
for the remote site by selecting Session Setup from the Options menu.



The Connect Dialog Box

The Connect dialog box lets you select a session name so that you can connect to the 
remote site it references. The Connect dialog box contains the following fields and 
buttons:

Session This field lets you select the session name that identifies the remote 
site you want to access. 

OK Clicking on this button exits the Connect dialog box and tries to 
establish a connection with the remote site.

Cancel Clicking on this button exits the Connect dialog box without trying to 
establish a connection to the remote site.

Note: The Connect menu item is grayed-out and cannot be selected if a connection is 
already established or if the application is in Interactive mode (the screen is available
for typing commands to, and displaying responses from, the modem or remote site).



Disconnect

The Disconnect menu item disconnects (hangs up) the current connection.

Note: If no connection is currently established, the Disconnect menu item is grayed-
out and cannot be selected.



The Stop! Menu

Selecting the Stop! menu stops any dialing or connecting in progress. This menu is 
only enabled when you are in the process of connecting to a remote site.



The Options Menu

The Options pulldown menu contains the following menu items:
Preferences 
Modem Port Setup 
Session Setup 
Auto Connect Setup 
Auto Connect Enable 



Preferences

The Preferences menu item lets you select certain options and display additional 
pulldown menus and menu items that enable you to customize the look and feel of 
the PPP/SLIP Connect application. 

When you select Preferences, the Preferences dialog box opens.



The Preferences Dialog Box

The Preferences dialog box lets you select certain options and display additional 
pulldown menus and menu items that enable you to customize the look and feel of 
the PPP/SLIP Connect application. The Preferences dialog box contains the following fields 
and buttons:

Administrative Mode

If this box is selected, additional menus and menu items are 
displayed in the PPP/SLIP Connect window that enable you to 
customize the SLIP/PPP Connect application. For a description of the 
additional pulldown menus and menu items available, refer to 
Administrative Mode.

Beep On Connect
If this box is selected, an audible beep sounds when a connection is 
made to a remote site.

Beep on Disconnect
If this box is selected, an audible beep sounds when a connection to a
remote site is terminated.

Disconnect on PPP/SLIP Connect Exit
If this box is selected, any current connection to a remote site will 
disconnect when you exit the PPP/SLIP Connect application.

Disconnect on Windows Exit
If this box is selected, any current connection to a remote site will 
disconnect when you exit Windows.

Display Modem Status
If this box is selected, the status of the modem is displayed by the 
Modem Status applet. The Modem applet displays the following status of the
modem:

RI (Ring Indicator)
CD (Carrier Detect)
RS (Request to Send)
CS (Clear to Send)
RD (Receive Data)
SD (Send data)

Handshake Logging
If this box is selected, all handshake messages will be displayed in 
the display area if Log to Screen is selected in the Options menu, or 
in the TCP Pro Console window if Log to Console is selected in the 
Options menu. 
Note: Log to Screen and Log to Console are only available from the 
Options menu if you are in Administrative mode. 

Show Connect Time when Minimized
If this box is selected, the elapsed time of the connection is displayed
while the PPP/SLIP Connect application is minimized.



Show IP Addresses on Connect
If this box is selected, all current settings for the IP address, Gateway 
Address, Subnet Mask, and DNS Address will be displayed in the 
Show IP address dialog box when a connection is being made to a 
remote site. 

Start Minimized
If this box is selected, the PPP/SLIP Connect application appears as an
icon on your screen when it is started. If this box is not selected, the 
PPP/SLIP Connect window is displayed on your screen when the 
application is started.

OK Clicking on this button applies the settings, then exits the Preferences
dialog box. 

Cancel Clicking on this button exits the Preferences dialog box without 
applying the settings. 



Modem Port Setup

The Modem Port Setup menu item lets you configure your modem for use with the 
PPP/SLIP Connect application.

When you select the Modem Port Setup menu item, the Modem Port Setup dialog box 
opens.



The Modem Port Setup Dialog Box

The Modem Port Setup dialog box lets you configure your modem for use with the 
PPP/SLIP Connect application. It contains the following fields and buttons:

COM Port Port lets you identify the COM port to which your modem is attached.
Baud Rate lets you select the baud rate you want to use from the 
drop-down list.

Port Addresses

Clicking on this button presents the following fields, which let you set 
non-standard COM port addresses:
IRQ lets you select the IRQ address for the COM port. If you select 
System, the IRQ value is obtained from the Windows SYSTEM.INI file. If 
you select Default, the default IRQ address for the COM port specified 
is used. If you select Custom, you must specify an IRQ address in the 
Custom field. The other choices are for predefined IRQ addresses.
IO Addr lets you select the IO address for the COM port. If you select 
System, the IO value is obtained from the Windows SYSTEM.INI file. If 
you select Default, the default IO address for the COM port specified is
used. If you select Custom, you must specify an IO address in the 
Custom field. The other choices are for predefined IO addresses.

Modem This field lets you select the type of modem that is attached to your 
PC. If you are not sure of your modem type, or your modem type 
does not appear in the list, select Default Modem Settings.

OK Clicking on this button applies the settings to the PPP/SLIP Connect 
application and exits the Modem Port Setup dialog box.

Cancel Clicking on this button exits the Modem Port Setup dialog box without 
applying the settings. 

Discover Selecting the Discover button attempts to automatically discover the 
comm port and modem type. This operation takes a few seconds.    
Pressing the Cancel button while Discover is in progress aborts the 
discovery operation.

Help Clicking on this button shows this help information.



Session Setup

The Session Setup menu item lets you define a session. A session is a collection of 
information that describes the way you access a particular remote site. It consists of 
the session name, the site name, the COM port where your modem is connected, user
authentication information (user name and password), and dialing information. When 
you select Session Setup, the Session Setup dialog box  opens.

IMPORTANT: If your network administrator has not provided you with a SITE.INI file, 
you must first provide information about the remote site before you define a session 
by selecting Site Setup from the Options menu. (Site Setup is available only when you
are in Administrative Mode.)



The Session Setup Dialog Box 

The Session Setup dialog box lets you define a session. A session is a collection of 
information that describes the way you access a particular remote site. It consists of 
the session name, the site name, the COM port where your modem is connected, user
authentication information (user name and password), and dialing information. 

 The Session Setup dialog box contains the following fields and buttons:
Session This field lets you enter a descriptive name for the session you want 

to define. If you want to edit an existing session, you can select the 
session from the drop-down list.

Site This field lets you select the name of the remote site to which the 
session specified above connects. 

Modem Port This field lets you select the COM port that the session specified 
above will use to connect to the remote site. Select a COM port from 
the drop-down list. 

Dialing Phone Nos displays the list of phone numbers defined for the remote 
site specified in the Site field. The phone numbers are dialed in the 
order presented in the list. However, numbers beginning with the 
Local Area Code specified for the session are dialed before other 
numbers. If a number is busy, the next number in the list is dialed. 
When all the numbers in the list have been dialed, and if the value for
Retries is greater than zero (0), the application waits for the number 
of seconds specified in the Wait field, described below, then the 
dialing sequence begins again. If no connection is made after the 
specified number of retries, the attempt to connect is abandoned.
To add a number to the list, type the number in the Phone Nos box. 
Enter one phone number on a line and use the Enter key to end a 
line. You can enter a maximum of ten phone numbers.
Local Area Code lets you enter the local area code where your modem 
is located. If a telephone number in the remote site dialing list begins
with this code, the code is removed from the phone number in the 
dialing sequence. This allows you to provide full telephone numbers 
for sites (for example, area code plus local number), however, a 
session can be in the same or a different area code.
Area Code Prefix lets you enter the string that is sent prior to the area 
code if the local area code is sent as part of the telephone number. 
Public telephone systems generally require 1 to precede the area 
code, however, some local private exchanges do not.

Dialing Options

This button lets you provide a prefix and suffix for the telephone 
numbers of a remote site. Clicking on this button presents the Session
Dialing Options   dialog box,  .

Set Exec Options

Selecting this button will take you to the Set Exec Options dialog box. 
The Set Exec Options dialog allows specification of applications to be 
run before and after a remote connection is made and before and 
after disconnecting from the remote site.



Handshake Login

This button is only displayed if there is a handshake specified for 
connecting to the remote site and either a user name or password is 
required during the handshake. Clicking on this button displays the 
Handshake Login Setup   dialog box  .

PPP Options This button is only displayed if the remote access mode of the site is 
PPP and there are PPP options that can be associated with the 
session. Clicking on this button displays the Session PPP Options   dialog  
box.

OK Clicking on this button applies the settings and exits the Session Setup
dialog box. 

Cancel Clicking on this button exits the Session Setup dialog box without 
saving the settings.

Reset Clicking on this button resets all the settings in the Session Setup 
dialog box to their default values. (The default values are the values 
that were last saved to the configuration file.)

Remove Clicking on this button removes the session specified in the Session 
field together with its settings from the configuration file.



The Session Dialing Options Dialog Box

The Session Dialing Options dialog box lets you provide a prefix and suffix for the 
telephone numbers of a remote site. The Session Dialing Options dialog box contains 
the following fields and buttons:

Prefix This field lets you enter the string that is sent before the telephone 
number in the dialing sequence. For example, the number 9 is 
required to dial out of many private exchanges.

Suffix This field lets you enter the string that is sent after the telephone 
number in the dialing sequence. This could be used to send a calling 
card number.

Retries This field lets you specify the number of times the dialing sequence 
will be retried before abandoning the attempt. The default is 2. 

Wait This field lets you specify the number of seconds between each 
dialing sequence attempt. The default is 30 seconds.

OK Clicking on this button saves the information temporarily and returns 
you to the Session Setup dialog box where you must click on OK to 
save the information permanently.

Cancel Clicking on this button exits the Session Dialing Options dialog box 
without saving the information and returns you to the Session Setup 
dialog box.



The Session PPP Options Dialog Box

The Session PPP Options dialog box lets you set PPP options for a session. It contains 
the following fields and buttons:

Authentication This area is used to specify PPP authentication options.
Note: This area is enabled only if PAP or CHAP authentication and the
Get User Name From Session Options box is selected in the Site PPP 
Options dialog box.
Prompt for User Name    If this box is selected, you will be prompted to 
enter a user name during handshaking with a remote site. If this box 
is not selected, you must supply a user name in the User Name field, 
described below.
User Name lets you enter your user name so that it is sent to the 
remote site automatically during handshaking. This field is disabled if
the Prompt for User Name box is selected.
Prompt for Password    If this box is selected, you will be prompted to 
enter a password during handshaking with a remote site. If this box is
not selected, you must supply a password in the Password field, 
described below.
Password lets you enter your password so that it is sent to the remote
site automatically during handshaking. This field is disabled if the 
Prompt for Password box is selected.

Protocols This area is used to select the network protocol(s) to be used with the
session. This area is enabled only if Get Protocols From Session Options 
is selected in the Site PPP Options dialog box. 
IP    If you select this box, the IP protocol is requested during PPP 
negotiation with the remote site.
IPX    If you select this box, the IPX protocol is requested during PPP 
negotiation with the remote site.

LCP Options Clicking on this button lets you set the following LCP (Link Control 
Protocol) options.
Note: This button is enabled only if you select Get LCP Options from 
Session Options in the Site PPP Options dialog box.
Asynch Control Char Map lets you enter the control characters you want
to map so that they can be used on an asynchronous link. The 
default, expressed in hexadecimal, is FFFFFFFF. This indicates that all 
control characters are mapped. For more detailed information about 
Async-Control-Character Map, refer to RFC 1548.
Protocol Field Compression    If this box is selected, Protocol-Field-
Compression is enabled (if the first byte of the Protocol field is zero, it
is omitted in non-LCP frames).
Address and Control Field Compression    If this box is selected, Address-
and-Control-Field-Compression is enabled (address and control bytes 
are omitted in non-LPC frames).

IPCP Options Clicking on this button lets you set the following IPCP option.



Local IP Address lets you enter your IP address.
Note: This button is enabled only if you select Get Local IP Address 
from Session Options in the Site PPP Options dialog box.

IPXCP Options Clicking on this button lets you set the following IPXCP options:
Machine Address lets you enter your MAC card address so that it is 
sent to the remote site automatically during handshaking.
Network ID lets you enter your network ID so that it is sent to the 
remote site automatically during handshaking.
Note: This button is enabled only if the IPX protocol is supported.

OK Clicking on this button applies the settings temporarily and returns 
you to the Session Setup dialog box where you must click on OK to 
save the information permanently.

Cancel Clicking on this button exits the Session PPP Options dialog box 
without saving the information and returns you to the Session Setup 
dialog box.



The Handshake Login Setup Dialog Box

The Handshake Login Setup dialog box is used to set authentication parameters (such 
as user name and password) needed during handshaking with the remote site. This 
authentication is independent of any PPP authentication that may be needed.

The Handshake Login Setup dialog box contains the following fields and buttons:
User Name Prompt for User Name    If this box is selected, you will be prompted to 

enter a user name during handshaking with the remote site (if the 
site requires a user name). If this box is not selected, you must enter 
your user name in the User Name field, described below.
User Name lets you enter your user name so that it is sent to the 
remote site automatically during handshaking. This field is disabled if
the Prompt for User Name field is selected.

Password Prompt for Password    If this box is selected, you will be prompted to 
enter a password during handshaking with the remote site (if the site 
requires a password). If this box is not selected, you must enter your 
password in the Password field, described below.
Password lets you enter your password so that it is sent to the remote
site automatically during handshaking. This field is disabled if the 
Prompt for Password field is selected.

OK Clicking on this button applies the settings temporarily and returns 
you to the Session Setup dialog box where you must click on OK to 
save the information permanently.

Cancel Clicking on this button exits the Handshake Login Setup dialog box 
without applying the settings and returns you to the Session Setup 
dialog box.



Auto Connect Setup

The Auto Connect Setup menu item configures the PPP/SLIP Connect application to 
automatically establish a connection to a remote site when the first Winsock-related 
network request is made. The connection is maintained for a set period of time after 
the Winsock-related network activity ceases.

When you select Auto Connect Setup, the Auto Connection Setup   dialog box   opens. 

Note: To enable the auto connect feature, you must select Auto Connect Enable from 
the Options menu after providing the information in the   Auto Connection Setup   dialog   
box. To disable the auto connect feature at any time, deselect Auto Connect Enable 
from the Options menu.



Auto Connection Setup Dialog Box

The Auto Connection Setup dialog box lets you configure the PPP/SLIP Connect 
application to automatically establish a connection to a remote site when the first 
Winsock-related network request is made. The connection is maintained for a set 
period of time after Winsock-related network activity ceases.

The Auto Connection Setup dialog box contains the following fields and buttons:
Session This field lets you select the session containing the information for 

the remote site to which you want to automatically connect.
Inactivity Timeout

This field lets you specify the number of seconds after the Winsock-related 
network activity ceases that the connection is automatically disconnected. The 
default is 180 seconds. If you specify zero (0), the Inactivity Timeout feature is 
disabled. 

Disconnect Immediately on Application Exit

If you select this box, the connection to the remote site is terminated 
immediately after the last application using Windows Sockets exits.

OK Clicking on this button applies the settings and exits the Auto Connect 
Setup dialog box.

Cancel Clicking on this button exits the Auto Connect Setup dialog box without 
saving the settings.



Auto Connect Enable

The Auto Connect Enable menu item enables the auto connect feature. A check mark 
next to the Auto Connect Enable menu item indicates that it is selected.

Note: Before you can enable the auto connect feature, you must set it up by 
selecting Auto Connect Setup from the Options menu.



Administrative Mode

When Administrative Mode is selected in the Preferences dialog box (accessed by 
selecting Preferences from the Options menu), the following additional pulldown menus
and menu items are available.

The File menu contains the following additional menu items:
Clear Screen Printer Setup
Print Screen Print Selection
Save Screen Save Selection

The Edit pulldown menu is displayed only when you are in Administrative mode. The 
Edit menu contains the following:

Copy
Paste

The Connect menu contains the following additional menu items:
Interactive Set IP Address
SLIP Mode

The Status pulldown menu is displayed only when you are in Administrative mode. 
The Status menu contains the following menu items:

Driver Status 

Connection Status 

The Options pulldown menu contains the following additional menu items:
Site Setup Background Color Setup 
Text Color Setup Screen Font Setup
Show Time Log to Screen
Log to Console Log to File
Log File Setup



Clear Screen

The Clear Screen menu item deletes the data displayed in the display area of the 
PPP/SLIP Connect window.



Printer Setup

The Printer Setup menu item lets you select a printer from which to print the data 
currently displayed in the display area. Selecting Printer Setup presents the Print 
Setup dialog box, which lets you select a printer locally or on the network. You can 
also select the orientation and size of the paper.



Print Screen

The Print Screen menu item prints all the data currently displayed in the display area 
to a printer. To specify a printer, select Printer Setup.



Print Selection

The Print Selection menu item prints specific data selected in the display area to a 
printer. To specify a printer, select Printer Setup.

Note: If no data is selected in the display area, the Print Selection menu item is 
grayed-out and cannot be selected.



Save Screen

The Save Screen menu item saves to a file all the data currently displayed in the 
display area. Selecting Save Screen presents the Save Screen Image dialog box, 
which lets you specify a file name, directory, and drive where you want to save the 
data.



Save Selection

The Save Selection menu item saves to a file specific data selected in the display 
area. Selecting Save Selection presents the Save Screen Image dialog box, which lets 
you specify a file name, directory, and drive where you want to save the selected 
data.

Note: If no data is selected in the display area, the Save Selection menu item is 
grayed-out and cannot be selected.



Copy

The Copy menu item copies the data selected in the display area to the Windows 
clipboard. 

Note: If no data is selected in the display area, the Copy menu item is grayed-out 
and cannot be selected.



Paste

The Paste menu item pastes the data in the Windows clipboard to the cursor position 
in the display area.

Note: If no data is present in the Windows clipboard, the Paste menu item is grayed-
out and cannot be selected.



Interactive

The Interactive menu item enters Interactive mode. In Interactive mode, the display 
area of the PPP/SLIP Connect window is used to type characters to the modem or the 
remote site. Only characters echoed from the modem or remote site are displayed in 
the screen area. Interactive mode is typically used when experimenting with a 
modem or a remote site (for example, working out the handshake sequence).

To exit Interactive mode, type Ctrl Z or deselect the Interactive menu item. 

When you select Interactive, the Interactive dialog box opens.



The Interactive Dialog Box

The Interactive dialog box lets you enter Interactive mode so that you can 
experiment with a modem or a remote site. In Interactive mode, the display area of 
the PPP/SLIP Connect window is used to type characters to the modem or the remote 
site.

The Interactive dialog box contains the following fields and buttons:
Modem Port This field lets you select the COM port to which your modem is 

attached.
OK Selecting this button closes the Interactive dialog box and enters 

Interactive mode.
Cancel Selecting this button closes the Interactive dialog box without 

entering Interactive mode.



Set IP Address

The Set IP Address menu item lets you specify various IP address components (for 
example, the workstation IP address, gateway address, and so on) so that they can 
be transmitted to the protocol driver. This is typically used when experimenting with 
a remote site. When you select Set IP Address, the The Set IP Addresses dialog box 
opens. 



The Set IP Address Dialog Box

The Set IP Addresses dialog box lets you identify certain IP addresses that your PC 
must use when communicating with the remote site. (This is necessary if IP address 
information is not included in the handshaking sequence.)

The Set IP Address dialog box contains the following fields and buttons:
IP Address This field lets you enter the IP address assigned to your PC by the 

remote site. If the remote access mode is PPP or if the IP address is 
obtained during a handshaking sequence, leave this field empty or 
enter 0.0.0.0.

Gateway This field lets you enter the Gateway address that your PC must use 
to access the remote site. This address should provided to you by the
remote site. If the remote access mode is PPP or if the Gateway 
address is obtained during a handshaking sequence, leave this field 
empty or enter 0.0.0.0

Subnet Mask This field lets you enter the subnet mask that your PC uses to access 
the remote site. This address should be provided to you by the 
remote site. If you leave this field blank or type 0.0.0.0, a subnet 
mask is computed from the IP address.

DNS Address This field lets you enter the Domain Name Server address that your 
PC uses to access the remote site. This address should be provided to
you by the remote site.

OK Clicking on this button saves the information temporarily and returns 
you to the Site Setup dialog box where you must click on OK to save 
the settings permanently.

Cancel Clicking on this button disregards any changes you made and returns
you to the Site Setup dialog box.



SLIP Mode

The SLIP Mode menu item enters SLIP mode. This is typically used when you are 
establishing a connection manually in Interactive mode. A check mark appears next 
to the SLIP Mode menu item when it is selected.

Note: The SLIP Mode menu item can only be selected when you are in Interactive 
mode and a connection has been established. 



Driver Status

The Driver Status menu item displays information in the display area about the PPP/ 
SLIP driver. A check mark appears next to the Driver Status menu item when it is 
selected.



Connection Status

The Connection Status menu item displays information about the connection that is 
currently established to a remote site. A check mark appears next to the Connection 
Status menu item when it is selected.



Site Setup

The Site Setup menu item lets you define information about a remote site (such as 
telephone numbers and a handshaking sequence) that generally does not change 
from session to session. This information may be provided to you by your network 
administrator in a file called SITE.INI.

Note: If a SITE.INI. file is not provided to you, you must provide information in the 
Site Setup dialog box about the remote site you want to access. (The SITE.INI file is 
created automatically by TCP Pro the first time you define a site.)



The Site Setup Dialog Box

The Site Setup dialog box lets you define information about a remote site (such as 
telephone numbers and a handshaking sequence). This information should be 
provided to you by your network administrator in a file called SITE.INI.

Note: If a SITE.INI file is not provided to you, you must create your own SITE.INI 
file by providing information in the Site Setup dialog box. (The SITE.INI file is 
created automatically by TCP Pro the first time you define a site and click on the OK 
button.)

The Site Setup dialog box contains the following fields and buttons:
Site This field lets you enter the name of a remote site or select a site 

from the drop-down list to edit an existing site.
Remote Access Type 

This area lets you select the type of protocol used by the remote site 
(PPP or SLIP):
PPP    Select this option if the remote site uses PPP.
SLIP    Select this option if the remote site uses SLIP.

Dialing Phone Nos lets you enter a list of phone numbers for the remote site 
specified in the Site field. The phone numbers are dialed in the order 
presented in the list. However, numbers beginning with the Local 
Area Code specified for the session are dialed before other numbers. 
If a number is busy, the next number in the list is dialed. When all the
numbers in the list have been dialed, and if the value for Retries is 
greater than zero (0), the application waits for the number of seconds
specified in the Wait field, described below, then the dialing sequence
begins again. If no connection is made after the specified number of 
retries, the attempt to connect is abandoned.
To add a number to the list, type the number in the Phone Nos box. 
Enter one phone number on a line and use the Enter key to end a 
line. You can enter a maximum of ten phone numbers.
Retries specifies the number of times the dialing sequence will be 
retried before abandoning the attempt. The default is 2.
Wait specifies the number of seconds between each dialing sequence 
attempt. The default is 30 seconds.
Note: Many of the above fields also appear in the Session Setup 
dialog box, where they can be changed for individual dial-up 
sessions.

Handshake This button lets you define the handshaking sequence required by 
the remote site. Clicking on this button displays the Handshake Setup     
dialog box.

PPP Options This button lets you define PPP options for a remote site. Clicking on 
this button displays the Site PPP Options dialog box.
Note: This button is displayed only if the remote access type for the 
site is PPP.



IP Addresses This button lets you set certain IP addresses that your PC must use 
when communicating with the remote site. (This is necessary if IP 
address information is not included in the handshaking sequence.) 
Clicking on this button displays the Set IP Addresses   dialog box  .

OK Clicking on this button applies the settings and exits the Site Setup 
dialog box. 

Cancel Clicking on this button exits the Site Setup dialog box without saving 
the settings.

Reset Clicking on this button resets all the site options (including the site 
name) to their default values. (The default values are those specified 
in the SITE.INI file.)

Remove Clicking on this button deletes the site specified in the Site field. 



The Handshake Setup Dialog Box

The Handshake Setup dialog box lets you define the handshaking sequence required by
the remote site. A handshaking sequence consists of an exchange of messages 
between the remote site and your PC. This exchange is usually required to login to 
the remote site. The Handshake Setup dialog box contains the following fields and 
buttons:

Handshake Kind
Auto Handshake - Select this option if you want to create a 
handshaking sequence that is sent automatically to the remote site. 
See Auto Handshake below.
Interactive Handshake - Select this option if you want to interact 
directly with the remote site. The display area is used for conversing 
with the remote site. See Interactive Handshake below.

Auto Handshake
CR on Connect specifies which character sequence is sent to the 
remote site to begin the handshaking sequence. The options are CR 
(Carriage Return), CRLF (Carriage Return and Line Feed), LF (Line Feed), or 
NONE. The default is NONE.

Delay  specifies the number of seconds the PPP/SLIP Connect 
application must wait after the modem connects before sending the 
character sequence specified in CR on Connect, described above. The
default is 0 (zero) seconds.

Handshake Event
This is the area where the handshake script is entered. You can scroll 
through the script using the scroll bar to the right. This title indicates 
the handshake event that is currently displayed as well as the total 
number of events. A maximum of ten events can be specified.
Recv specifies the string received from the remote site that signals 
the beginning of the handshake event.
Kind specifies the type of data being received from the remote site. 
The following data types can be selected. The default is DONTCARE.

DNSADDRESS  Indicates that the string contains the Domain Name
Server (DNS) address to be used by your PC.
DONTCARE    Indicates that there is no special processing 
associated with this string.
ERRORSTR    Indicates that the string is paired with, and is an 
alternative to, the event that immediately precedes it. The 
receipt of this string from the remote site indicates that an error
occurred. If the error string is received, the string in the Send 
field is displayed in a message box.
GWADDRESS    Indicates that the string contains the Gateway 
address to be used by your PC.
IPADDRESS    Indicates that the string contains the IP address that
is assigned to your PC.



PASSWORD    Indicates that the string is a prompt for a password to
be sent back to the remote site.
PROMPT(HIDE)    Indicates that the string is a prompt to the end 
user. HIDE indicates that the data entry field is in password 
mode (characters in the field appear as asterisks). For a 
description of the prompt strings, refer to PROMPT (SHOW) below.
PROMPT(SHOW)    Indicates that the string is a prompt to the end 
user. SHOW indicates that the data entry field is in normal mode 
(characters in the field appear normally). The prompt strings are
described below:
[(title string)[(prompt string)]]recv string
Brackets ([]) indicate optional parts.
title string, if present, provides the title for the prompting dialog
box.
prompt string, if present, provides prompting text in the 
prompting dialog box. If omitted, the recv string is used as 
the prompting text.
recv string is the string expected from the remote site.
Examples:
In the following example, MVS Login is used as the title in the 
prompting dialog box, Please enter..... is used as the 
prompting text. enter account ..... is the receive string.
(MVS Login)(Please enter your Account Name, User Name,
and Password:)enter account name, username, and 
password: 
In the following example, MVS Login is used as the title in the 
prompting dialog box, enter account....... is used as the 
prompting text and the receive string.
(MVS Login)enter account name, username, and password:
In the following example, the current session name is used as 
the title, enter account...... is used as the prompting text 
and the receive string.
enter account name, username, and password:
SUBNETMASK    Indicates that the string contains the Subnet mask 
to be used by your PC.
TIMEOUT  Indicates that the string is a customized message to 
the user if a timeout occurs while waiting for a handshake string
from the remote site. The string in the Send field is presented in 
a message box.
USERNAME    Indicates that the string is a prompt for a user name 
to be sent back to the remote site.

Wait specifies the number of seconds to wait for the receipt of the 
string specified in the Recv field. If the string is not received within 
this time period, the connection is abandoned. The default is 0 (zero) 
seconds.



Send specifies the string that is sent in response to the receipt of the 
Recv string. It is normal to leave For PASSWORD and USERNAME empty. 
The password and user name are then taken from the session 
information. If a string is present for PASSWORD or USERNAME, the string 
is sent and any password or user name in the associated session is 
ignored. If the string is for a password, it is not encrypted in the 
SITE.INI file.
Append CR on Send    specifies that a Carriage Return is appended to 
the Send string when it is sent to the remote site.
Append Clicking on this button appends an empty handshake 
event to the end of the handshake sequence.
Insert Clicking on this button inserts an empty 
handshake event before the one currently displayed.
Remove Clicking on this button deletes the currently displayed 
handshake event.

Interactive Handshake
Prompt for Phone Number - Select this option if you want to be 
prompted to enter the telephone number of the remote site. If this 
option is not selected, the telephone number is obtained from 
Session options.
Prompt for IP Address - Select this option if you want to be prompted 
to enter the IP addresses related to the remote site. If this option is 
not selected, the IP addresses are obtained from Site options or PPP 
negotiation.

OK Clicking on this button saves the settings temporarily and returns you
to the Site Setup dialog box where you must click on OK to save the 
settings permanently.

Cancel Clicking on this button disregards any changes you made and returns
you to the Site Setup dialog box.



The Site PPP Options Dialog Box

The Site PPP Options dialog box lets you set options for a remote site using PPP. The 
Site PPP Options dialog box contains the following fields and buttons:

Authentication This area is used to specify PPP authentication options. 
PAP    If you select this box, PAP (PPP Authentication Protocol) 
authentication is requested.
CHAP    If you select this box, CHAP authentication is requested.

PAP/CHAP Options

Get User Name From Session Options  If this box is selected, the user 
name must be specified in the Session PPP Options   dialog box  . If this 
box is not selected, you must specify your user name in the User 
Name field, described below.
User Name lets you enter your user name so that it will be sent to the 
remote site automatically during PAP/CHAP authentication. This field 
is disabled if the Get User Name From Session Options box is selected.
Get Password From Session Options  If this box is selected, you must 
specify your password in the Session PPP Options dialog box . If this 
box is not selected, you must specify your password in the Password 
field, described below.
Password lets you enter your password so that it will be sent to the 
remote site automatically during PAP/CHAP authentication. This field 
is disabled if the Get Password From Session Options box is selected.

Protocols This area is used to select the network protocols to be used during 
negotiation with the remote site.
Get Protocols From Session Parameters    If you select this box, you must 
select the network protocols to be used during negotiation with the 
remote site in the Session PPP Options   dialog box  .
IP    If you select this box, the IP protocol is requested during PPP 
negotiation with the remote site.
IPX    If you select this box, the IPX protocol is requested during PPP 
negotiation with the remote site.

LCP Options Clicking on this button lets you set the following LCP (Link Control 
Protocol) options:
Get LCP Options From Session Parameters    If you select this box, you 
must specify LCP options in the Session PPP Options   dialog box  . If this 
box is not selected, you must specify values for the fields described 
below:
Asynch Control Char Map lets you enter the control characters you want
to map so that they can be used on an asynchronous link. The 
default, expressed in hexadecimal, is FFFFFFFF. This indicates that all 
control characters are mapped. For more detailed information about 
Async-Control-Character Map, refer to RFC 1548.
Protocol Field Compression  If this box is selected, Protocol-Field-
Compression is enabled (if the first byte of the Protocol field is zero, it



is omitted in non-LCP frames). 
Address and Control Field Compression    If this box is selected, 
Address-and-Control-Field-Compression is enabled (address and 
control bytes are omitted in non-LCP frames). 

IPCP Options Clicking on this button lets you set the following IPCP options:
Get Local IP Address From Session Options  If this box is selected, you 
must specify the IP address of your PC in the Session PPP Options     
dialog box. 
Local IP Address lets you enter your IP address so that it will be sent to
the remote site automatically. This field is disabled if the Get Local IP 
Address From Session Options box is selected.

IPXCP Options Clicking on this button lets you set the following IPXCP options:
Get Machine Address From Session Options    If this box is selected, you 
must specify your MAC card address in the Session PPP Options   dialog   
box. 
Machine Address lets you enter your MAC card address so that it is 
sent to the remote site automatically during handshaking.
Get Network ID From Session Options  If this box is selected, you must 
specify your network ID in the Session PPP Options   dialog box  . 
Network ID lets you enter your network ID so that it is sent to the 
remote site automatically during handshaking.
Note: The IPXCP Options button is displayed only if the IPX protocol is 
supported.

OK Clicking on this button applies the settings temporarily and returns 
you to the Site Setup dialog box where you must click on OK to save 
the settings permanently.

Cancel Clicking on this button exits the Site PPP Options dialog box without 
applying the settings and returns you to the Site Setup dialog box.



The Set IP Addresses Dialog Box

The Set IP Addresses dialog box lets you identify certain IP addresses that your PC 
must use when communicating with the remote site. (This is necessary if IP address 
information is not included in the handshaking sequence.)

Note: The IP addresses set here override those specified in the Handshake Setup     
dialog box (accessed by selecting the Handshake button in the Site Setup dialog box).

The Set IP Address dialog box contains the following fields and buttons:
IP Address This field lets you enter the IP address assigned to your PC by the 

remote site. If the remote access mode is PPP or if the IP address is 
obtained during a handshaking sequence, leave this field empty or 
enter 0.0.0.0.

Gateway This field lets you enter the Gateway address that your PC must use 
to access the remote site. This address should be provided to you by 
a network administrator at the remote site. If the remote access 
mode is PPP or if the Gateway address is obtained during a 
handshaking sequence, leave this field empty or enter 0.0.0.0

Subnet Mask This field lets you enter the subnet mask that your PC uses to access 
the remote site. This address should be provided to you by a network 
administrator at the remote site. If you leave this field blank or type 
0.0.0.0, a subnet mask is computed from the IP address.

DNS Address This field lets you enter the Domain Name Server address that your 
PC uses to access the remote site. This address should be provided to
you by a network administrator at the remote site.

OK Clicking on this button saves the information temporarily and returns 
you to the Site Setup dialog box where you must click on OK to save 
the settings permanently.

Cancel Clicking on this button disregards any changes you made and returns
you to the Site Setup dialog box.



Background Color Setup

The Background Color Setup menu item lets you change the background color of the 
display area. When you select Background Color Setup, the Color dialog box opens 
displaying an array of colors. You can select one of the colors displayed or define your
own custom colors.



Text Color Setup

The Text Color Setup menu item lets you change the color of the text displayed in the
display area. When you select Text Color Setup, the Color dialog box opens displaying
an array of colors. You can select one of the colors displayed or define your own 
custom colors.



Screen Font Setup

The Screen Font Setup menu item lets you select the font you want to use for text in 
the display area. When you select Screen Font Setup, the Font dialog box opens. In 
this dialog box, you can select the font type (for example, courier), the font style, (for
example, bold), and the font size. The Sample area provides an example of how the 
text will appear. 



Show Time

The Show Time menu item lets you display the data in the display area with the date 
and time it was generated. A check mark appears to the left of the Show Time menu 
item when it is selected.



Log to Screen

The Log to Screen menu item lets you display in the display area all interactions with 
the modem and the remote site as well as any error messages that may occur during 
the time that the PPP/SLIP Connect application is running. A check mark appears to 
the left of the Log to Screen menu item when it is selected. 



Log to Console

The Log to Console menu item lets you display in the TCP Pro Console window all 
interactions with the modem and the remote site as well as any error messages that 
may occur while the PPP/SLIP Connect application is running. A check mark appears 
to the left of the Log to Console menu item when it is selected.



Log to File

The Log to File menu item saves to a file all interactions with the modem and the 
remote site as well as any error messages that are being generated while the 
PPP/SLIP Connect application is running. A check mark appears to the left of the Log 
to File menu item when it is selected.

Note: If you have not specified a file name, the Log to File menu item is grayed-out 
and cannot be selected. You must specify a    file name by selecting the Log File Setup
menu item.



Log File Setup

The Log File Setup menu item lets you specify a file name where you want to save all 
the information that is being generated while Log to File is selected. 

When you select Log File Setup, the Log File Setup dialog box opens. 



The Log File Setup Dialog Box

The Log File Setup dialog box contains the following fields and buttons:
File Name This field lets you specify the name of the file where you want to save

the information.
Open Mode Append adds new information to the end of the log file each time you 

start the PPP/SLIP Connect application.
Truncate deletes all old information from the log file each time you 
start the PPP/SLIP Connect application.

OK Clicking on this button saves the specified file name and exits the 
PPP/SLIP Connect application. 

Cancel Clicking on this button exits the Log File Setup dialog box without 
saving the file name.

Files Clicking on this button opens a dialog box that allows you to select a 
file on your PC or on the network where you want to save the 
information.



The Show IP address Dialog Box 

The Show IP Address dialog box displays all the IP addresses that were set for the 
current session so that you can make note of them if necessary. The dialog box 
contains the following fields and buttons:

IP Address This field displays the IP address for the current session.
Gateway This field displays the Gateway address for the current session.
Subnet Mask This field displays the Subnet Mask address for the current session.
DNS Address This field displays the DNS (Domain Name Server) address for the 

current session.
OK Clicking on this button exits the dialog box.



The IP Address Dialog Box

The IP Address Dialog Box appears if one or more IP address has not been set for the 
session. The dialog box contains a message explaining that one or more address is 
missing and asks you to enter the address in the appropriate field. (The field with the 
missing address is indicated with the word (missing).)    The dialog box contains the 
following fields and buttons:

IP Address This field should contain the IP address assigned to your PC by the 
remote site. If you do know this address, you must contact the 
remote site to obtain it.

Gateway Address This field should contain the Gateway address assigned to your 
PC by the remote site. If you do know this address, you must contact 
the remote site to obtain it.

Subnet Mask This field should contain the Subnet Mask address assigned to your 
PC by the remote site.    If you do know this address, you must 
contact the remote site to obtain it.

DNS Address This field should contain the Domain Name Server address that your 
PC must use to access the remote site. If you do know this address, 
you must contact the remote site to obtain it.

OK Clicking on this button closes the dialog box.



The Authentication Dialog Box

If you selected to be prompted for your user name and/or password during the 
handshaking sequence, the authentication dialog box opens allowing you to enter 
your user name and/or password.

The dialog box contains the following fields and buttons:
User Name This field lets you enter your user name for the current session.
Password This field lets you enter your password for the current session.
OK Clicking on this button confirms your entries and exits the dialog box.
Cancel Clicking on this box exits the dialog box without confirming your 

entries.



Set Exec Options dialog box.

The Set Exec Options dialog box contains the following fields and buttons:
OK Clicking on this button saves the information entered in the fields of 

the Set Exec Options dialog box and returns to the Session Setup 
dialog box. 

Cancel Clicking on this button returns to the Session Setup dialog box 
without saving any changes.

Help Clicking on this button displays help for the Set Exec Options dialog 
box.

Get Exec Options from Session Options           If this box is checked, a Set Exec Options 
button is displayed when this site is referenced by a Session.    A 
dialog box similar to this one is displayed.    If this is not checked, the 
other fields in this dialog box are enabled.

Before Connect This field should be filled in with the complete path, name, and 
parameters for an application to be executed when a connection is 
initiated.

After Connect This field should be filled in with the complete path, name, and 
parameters for an application to be executed after a successful 
connection is made.

Before Disconnect This field should be filled in with the complete path, name, and 
parameters for an application to be executed when disconnection is 
initiated.

After Disconnect This field should be filled in with the complete path, name, and 
parameters for an application to be executed after disconnection has 
been completed.

Wait The Wait check box associated with each parameter specifies 
whether or not the PPP/SLIP Connect application waits for the 
application to terminate before proceeding.    If checked, the Connect 
application waits; if not checked, the Connect application starts the 
specified application then immediately proceeds.

 




